ЕСЛИМН в Excel

ЕСЛИМН в Excel

Добрый день, уважаемые читатели и подписчики канала. Сегодня мы поговорим о новых функциях Excel. Одной из полюбившихся мне - ЕСЛИМН. 

Функция представляет собой привычную нам функцию ЕСЛИ, только без третьего аргумента - "Значение если ложь".

Зачем такой трюк? Всё просто - вспомним случай когда нужно учесть много условий. Приходилось звать функцию ЕСЛИ, указывать значение "Если истина", вкладывать следующую формулу ЕСЛИ и так до достижения нужного количества условий.

Вот тут и приходит на помощь функция ЕСЛИМН. Давайте взглянем на её синтаксис.

 

ЕСЛИМН в Excel

 

Нужно указать "логическое выражение" и "значение если истина". Всё.

Представим вот такую таблицу, где для каждого сотрудника нужно указать три условия для получения премии.

 

ЕСЛИМН в Excel

 

А теперь взглянем на формулу для этого столбца.

 

=ЕСЛИМН(B2>=$J$2;C2*0,25;B2>=$J$3;C2*0,35;B2>=$J$4;C2*0,5)

 

ЕСЛИМН в Excel

 

То есть нужно перечислить условия и результат их выполнения. Записывать можно как угодно, в рамках правил конечно же. Результат ниже.

 

ЕСЛИМН в Excel

 

В данном случае получается ошибка "Недопустимое значение". Она появилась из-за того, что не указана альтернатива - что будет если условие не выполняется. Это нормально. Воспользуемся помощью функции ЕСЛИОШИБКА.

 

=ЕСЛИОШИБКА(ЕСЛИМН(B2>=$J$2;C2*0,25;B2>=$J$3;C2*0,35;B2>=$J$4;C2*0,5);0)

 

В ней всего два аргумента - в первый (значение) подставим нашу формулу ЕСЛИМН, затем точку с запятой и 0, чтобы вместо ошибки нам показало его.

 

ЕСЛИМН в Excel

 

Протянув за маркер автозаполнения вниз - получим нужный результат и никаких зубодробительных конструкций из вложенных друг в друга функций!

Всем удачи! Вас может заинтересовать статья про примечания в Excel.

Автор записи: Иван

Добавить комментарий

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.